re = /(<countryChannel countryCode=".*\/>)/
str = '</articleMedia>
<channels>
<countryChannel countryCode="CountryCode"/> hghgg
</channels>
</article>
<countryChannel countryCode="CountryCode"/> hghgg
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end