package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<countryChannel countryCode=".*\/>)`)
var str = `</articleMedia>
<channels>
<countryChannel countryCode="CountryCode"/> hghgg
</channels>
</article>
<countryChannel countryCode="CountryCode"/> hghgg
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}