#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]{2}-\d{2}-Annual\sDSH\sAudit\.pdf$"
Local $sString = "A-14-Annual DSH Audit.pdf" & @CRLF & _
"AL-13-Annual DSH Audit.pdf" & @CRLF & _
"AL-1-Annual DSH Audit.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")