import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z]{2}-\\d{2}-Annual\\sDSH\\sAudit\\.pdf$";
final String string = "A-14-Annual DSH Audit.pdf\n"
+ "AL-13-Annual DSH Audit.pdf\n"
+ "AL-1-Annual DSH Audit.pdf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}