using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b((?:\w(?=\w*?(\w\2?\b)))+?)(\w\w?)\2\b";
string input = @"antidisestablishmentarianism
Half of everything is luck.
And the other half?
Fate.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}