import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?:\\w(?=\\w*?(\\w\\2?\\b)))+?)(\\w\\w?)\\2\\b";
final String string = "antidisestablishmentarianism \n"
+ "Half of everything is luck.\n"
+ "And the other half?\n"
+ "Fate.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}