re = /\b((?:\w(?=\w*?(\w\2?\b)))+?)(\w\w?)\2\b/m
str = 'antidisestablishmentarianism
Half of everything is luck.
And the other half?
Fate.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end