$re = '/\b((?:\w(?=\w*?(\w\2?\b)))+?)(\w\w?)\2\b/m';
$str = 'antidisestablishmentarianism
Half of everything is luck.
And the other half?
Fate.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);