use strict;
my $str = 'http://www.test.com/who12/foo
http://www.test.com/who1iiiiiiikskkskskdsdsdsdsds/foo
http://www.test.com/what1
http://www.test.com/what1?param=true
whatasjdklajslkdjaskljdksjadklsajdkasjdkasjdklajds
or
/what/ksjasdjsakldjalskjdklasjdkasjdklasjdl
';
my $regex = qr/\.com\/\K(?:who[^\/?\s]{2}|what[^\/?\s])(?:[^\/?\s]{5})?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}