re = /\.com\/\K(?:who[^\/?\s]{2}|what[^\/?\s])(?:[^\/?\s]{5})?/
str = 'http://www.test.com/who12/foo
http://www.test.com/who1iiiiiiikskkskskdsdsdsdsds/foo
http://www.test.com/what1
http://www.test.com/what1?param=true
whatasjdklajslkdjaskljdksjadklsajdkasjdkasjdklajds
or
/what/ksjasdjsakldjalskjdklasjdkasjdklasjdl
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end