import Foundation
let pattern = #"\.com\/\K(?:who[^\/?\s]{2}|what[^\/?\s])(?:[^\/?\s]{5})?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://www.test.com/who12/foo
http://www.test.com/who1iiiiiiikskkskskdsdsdsdsds/foo
http://www.test.com/what1
http://www.test.com/what1?param=true
whatasjdklajslkdjaskljdksjadklsajdkasjdkasjdklajds
or
/what/ksjasdjsakldjalskjdklasjdkasjdklasjdl
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)