using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"help";
string input = @"docker0: 172.17.0.1
eth2: 173.102.200.183
eth3: 172.16.0.2
lo: 127.0.0.1
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}