$re = '/help/';
$str = 'docker0: 172.17.0.1
eth2: 173.102.200.183
eth3: 172.16.0.2
lo: 127.0.0.1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);