import re
regex = re.compile(r"help")
test_str = ("docker0: 172.17.0.1\n"
"eth2: 173.102.200.183\n"
"eth3: 172.16.0.2\n"
"lo: 127.0.0.1\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")