// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"help").unwrap();
let string = "docker0: 172.17.0.1
eth2: 173.102.200.183
eth3: 172.16.0.2
lo: 127.0.0.1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}