// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/[^\/]*\/[^\/]*\/$").unwrap();
let string = "https://www.reddit.com/r/RationalPsychonaut/comments/5m4rhv/a_satirical_blog_about_enlightenment_in_everyday/
https://www.reddit.com/r/swift/comments/5mriaj/i_just_released_a_swift_wrapper_for_the_llvm_api/
";
let substitution = "/";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}