use strict;
my $str = 'var some_fnc1=function(a,b,c){var a = 1+1;b=a++;c=b+a;}var some_fnc2=function(a){some();and_one(a) return false;}var some_fnc3=function(z,x,y){new AnySome(/sdds/i);var ZZZ=1;}var some_fnc4=function(ololo){var b = 1+1;b=z++;c=b+a;}';
my $regex = qr/var (.*?)=function.*ZZZ/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}