import Foundation
let pattern = #"var (.*?)=function.*ZZZ"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"var some_fnc1=function(a,b,c){var a = 1+1;b=a++;c=b+a;}var some_fnc2=function(a){some();and_one(a) return false;}var some_fnc3=function(z,x,y){new AnySome(/sdds/i);var ZZZ=1;}var some_fnc4=function(ololo){var b = 1+1;b=z++;c=b+a;}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)