// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"var (.*?)=function.*ZZZ").unwrap();
let string = "var some_fnc1=function(a,b,c){var a = 1+1;b=a++;c=b+a;}var some_fnc2=function(a){some();and_one(a) return false;}var some_fnc3=function(z,x,y){new AnySome(/sdds/i);var ZZZ=1;}var some_fnc4=function(ololo){var b = 1+1;b=z++;c=b+a;}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}