#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*,\s*((?:(?!\sand\s)[^,\n])*)"
Local $sString = "flat 1, tower block, 34 long road, Major city" & @CRLF & _
"flat 1, tower block, 34 long road, town and parking space" & @CRLF & _
"34 short road, village on the river and carpark (7X3 8RG)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")