import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*,\\s*((?:(?!\\sand\\s)[^,\\n])*)";
final String string = "flat 1, tower block, 34 long road, Major city\n"
+ "flat 1, tower block, 34 long road, town and parking space\n"
+ "34 short road, village on the river and carpark (7X3 8RG)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}