using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*,\s*((?:(?!\sand\s)[^,\n])*)";
string input = @"flat 1, tower block, 34 long road, Major city
flat 1, tower block, 34 long road, town and parking space
34 short road, village on the river and carpark (7X3 8RG)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}