re = /.*,\s*((?:(?!\sand\s)[^,\n])*)/m
str = 'flat 1, tower block, 34 long road, Major city
flat 1, tower block, 34 long road, town and parking space
34 short road, village on the river and carpark (7X3 8RG)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end