$re = '/^\/index(|\.[php|html|htm]\w+)$/m';
$str = '/index
/index.html
/index.htm
/index.php
/index.ph';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);