re = /^\/index(|\.[php|html|htm]\w+)$/m
str = '/index
/index.html
/index.htm
/index.php
/index.ph'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end