$re = '/\q\=\"(.*?)\"/i';
$str = 'https://gcom.pdodev.aws.gartner.com/search/research?fc=facetKi:%22Technology%20Market%20Essentials%22&q="at&t"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);