re = /\q\=\"(.*?)\"/i
str = 'https://gcom.pdodev.aws.gartner.com/search/research?fc=facetKi:%22Technology%20Market%20Essentials%22&q="at&t"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end