#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\d*(\d)\1{4})\d{9}$"
Local $sString = "123456789" & @CRLF & _
"111156789" & @CRLF & _
"111116789" & @CRLF & _
"123499999" & @CRLF & _
"121314151" & @CRLF & _
"322222456" & @CRLF & _
"888888888" & @CRLF & _
"199999991" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")