$re = '/^(?!\d*(\d)\1{4})\d{9}$/m';
$str = '123456789
111156789
111116789
123499999
121314151
322222456
888888888
199999991
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);