re = /^(?!\d*(\d)\1{4})\d{9}$/m
str = '123456789
111156789
111116789
123499999
121314151
322222456
888888888
199999991
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end