package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` \w{4,6}:nil="true" xmlns.*\/>`)
var str = `
<SonOlcumIstasyon d3p1:nil="true" xmlns:d3p1="http://www.w3.org/2001/XMLSchema-instance" />
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}