const regex = / \w{4,6}:nil="true" xmlns.*\/>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' \\w{4,6}:nil="true" xmlns.*\\\/>', 'g')
const str = `
<SonOlcumIstasyon d3p1:nil="true" xmlns:d3p1="http://www.w3.org/2001/XMLSchema-instance" />
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}