re = / \w{4,6}:nil="true" xmlns.*\/>/
str = '
<SonOlcumIstasyon d3p1:nil="true" xmlns:d3p1="http://www.w3.org/2001/XMLSchema-instance" />
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end