import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(first|second|third|fourth)(?=(?:\\s*(?:,|and)\\s*(?:first|second|third|fourth))*\\s+section\\b)";
final String string = "1. something first, other and then second, third and fourth section\n\n"
+ "2. something first and other and then second, third and fourth section\n\n"
+ "3. something first, second other and then second, third and fourth section\n\n"
+ "4. fourth section\n\n"
+ "5. something first, second, third and fourth section\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}