re = /\b(first|second|third|fourth)(?=(?:\s*(?:,|and)\s*(?:first|second|third|fourth))*\s+section\b)/
str = '1. something first, other and then second, third and fourth section
2. something first and other and then second, third and fourth section
3. something first, second other and then second, third and fourth section
4. fourth section
5. something first, second, third and fourth section
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end