const regex = /\b(first|second|third|fourth)(?=(?:\s*(?:,|and)\s*(?:first|second|third|fourth))*\s+section\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(first|second|third|fourth)(?=(?:\\s*(?:,|and)\\s*(?:first|second|third|fourth))*\\s+section\\b)', 'g')
const str = `1. something first, other and then second, third and fourth section
2. something first and other and then second, third and fourth section
3. something first, second other and then second, third and fourth section
4. fourth section
5. something first, second, third and fourth section
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}