$re = '/\b(first|second|third|fourth)(?=(?:\s*(?:,|and)\s*(?:first|second|third|fourth))*\s+section\b)/';
$str = '1. something first, other and then second, third and fourth section
2. something first and other and then second, third and fourth section
3. something first, second other and then second, third and fourth section
4. fourth section
5. something first, second, third and fourth section
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);