#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)((([A-Za-z]{3,9}:(?:\/\/)?)(?:[\-;:&=\+\$,\w]+@)?[A-Za-z0-9\.\-]+|(?:www\.|[\-;:&=\+\$,\w]+@)[A-Za-z0-9\.\-]+)((?:\/[\+~%\/\.\w\-_]*)?\??(?:[\-\+=&;%@\.\w_]*)#?(?:[\.\!\/\\\w]*))?)(:\d+)?\/?(\w+)?\/?"
Local $sString = "mongodb://localhost:27017/db/http://localhost:27017/db" & @CRLF & _
"http://app.myxteam.com/Task/?id=477342" & @CRLF & _
"https://play.google.com/store/apps/details?id=vsoft.rms.online.advance" & @CRLF & _
"http://api.quanlytructuyen.com/wsvLetwin/" & @CRLF & _
"http://192.168.1.30:65" & @CRLF & _
"http://localhost:20/" & @CRLF & _
"https://regex101.com/r/VC5MsA/1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")