$re = '/((([A-Za-z]{3,9}:(?:\/\/)?)(?:[\-;:&=\+\$,\w]+@)?[A-Za-z0-9\.\-]+|(?:www\.|[\-;:&=\+\$,\w]+@)[A-Za-z0-9\.\-]+)((?:\/[\+~%\/\.\w\-_]*)?\??(?:[\-\+=&;%@\.\w_]*)#?(?:[\.\!\/\\\\\w]*))?)(:\d+)?\/?(\w+)?\/?/mi';
$str = 'mongodb://localhost:27017/db/http://localhost:27017/db
http://app.myxteam.com/Task/?id=477342
https://play.google.com/store/apps/details?id=vsoft.rms.online.advance
http://api.quanlytructuyen.com/wsvLetwin/
http://192.168.1.30:65
http://localhost:20/
https://regex101.com/r/VC5MsA/1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);