use strict;
my $str = 'mongodb://localhost:27017/db/http://localhost:27017/db
http://app.myxteam.com/Task/?id=477342
https://play.google.com/store/apps/details?id=vsoft.rms.online.advance
http://api.quanlytructuyen.com/wsvLetwin/
http://192.168.1.30:65
http://localhost:20/
https://regex101.com/r/VC5MsA/1';
my $regex = qr/((([A-Za-z]{3,9}:(?:\/\/)?)(?:[\-;:&=\+\$,\w]+@)?[A-Za-z0-9\.\-]+|(?:www\.|[\-;:&=\+\$,\w]+@)[A-Za-z0-9\.\-]+)((?:\/[\+~%\/\.\w\-_]*)?\??(?:[\-\+=&;%@\.\w_]*)#?(?:[\.\!\/\\\w]*))?)(:\d+)?\/?(\w+)?\/?/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}