import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((([A-Za-z]{3,9}:(?:\\/\\/)?)(?:[\\-;:&=\\+\\$,\\w]+@)?[A-Za-z0-9\\.\\-]+|(?:www\\.|[\\-;:&=\\+\\$,\\w]+@)[A-Za-z0-9\\.\\-]+)((?:\\/[\\+~%\\/\\.\\w\\-_]*)?\\??(?:[\\-\\+=&;%@\\.\\w_]*)#?(?:[\\.\\!\\/\\\\\\w]*))?)(:\\d+)?\\/?(\\w+)?\\/?";
final String string = "mongodb://localhost:27017/db/http://localhost:27017/db\n"
+ "http://app.myxteam.com/Task/?id=477342\n"
+ "https://play.google.com/store/apps/details?id=vsoft.rms.online.advance\n"
+ "http://api.quanlytructuyen.com/wsvLetwin/\n"
+ "http://192.168.1.30:65\n"
+ "http://localhost:20/\n"
+ "https://regex101.com/r/VC5MsA/1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}