#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\h)(?!.*\h[*?])(?!.*[*?]\h)(?:[?\h]*[a-zA-Z0-9]){2}[a-zA-Z0-9?\h]*\*?$"
Local $sString = "abcd" & @CRLF & _
"?bcd" & @CRLF & _
"ab??" & @CRLF & _
"ab*" & @CRLF & _
"ab?*" & @CRLF & _
"??cd" & @CRLF & _
"a?????b????*" & @CRLF & _
"ab cd" & @CRLF & _
"*ab" & @CRLF & _
"???" & @CRLF & _
"ab? cd" & @CRLF & _
"ab ?d" & @CRLF & _
"ab *" & @CRLF & _
"a ? b" & @CRLF & _
" abcd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")