using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\h)(?!.*\h[*?])(?!.*[*?]\h)(?:[?\h]*[a-zA-Z0-9]){2}[a-zA-Z0-9?\h]*\*?$";
string input = @"abcd
?bcd
ab??
ab*
ab?*
??cd
a?????b????*
ab cd
*ab
???
ab? cd
ab ?d
ab *
a ? b
abcd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}