import Foundation
let pattern = #"^(?!\h)(?!.*\h[*?])(?!.*[*?]\h)(?:[?\h]*[a-zA-Z0-9]){2}[a-zA-Z0-9?\h]*\*?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abcd
?bcd
ab??
ab*
ab?*
??cd
a?????b????*
ab cd
*ab
???
ab? cd
ab ?d
ab *
a ? b
abcd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)