import re
regex = re.compile(r"^(?!\h)(?!.*\h[*?])(?!.*[*?]\h)(?:[?\h]*[a-zA-Z0-9]){2}[a-zA-Z0-9?\h]*\*?$", flags=re.MULTILINE)
test_str = ("abcd\n"
"?bcd\n"
"ab??\n"
"ab*\n"
"ab?*\n"
"??cd\n"
"a?????b????*\n"
"ab cd\n"
"*ab\n"
"???\n"
"ab? cd\n"
"ab ?d\n"
"ab *\n"
"a ? b\n"
" abcd")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")