# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/:[^:\s]+:|<:[^:\s]+:[0-9]+>|<a:[^:\s]+:[0-9]+>//g;t' <<< "TEMPLATES
--------------------------------------------------------------
:emote:
<:emote:189855563893571595>
<a:emote:18985556389571595>
OK MESSAGE
--------------------------------------------------------------
:emote:<:emote:189855563893571595><a:emote:189855563893571595>
BAD MESSAGE
--------------------------------------------------------------
:emote::asdf ::emote::: <:hey:>
<:a:emote:> hey
DOES IT WORK?
--------------------------------------------------------------
In the box below (click \"Substitution\" at the bottom if you can't see it) is all the characters that don't match the regex and will trigger your system to delete the message."