import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":[^:\\s]+:|<:[^:\\s]+:[0-9]+>|<a:[^:\\s]+:[0-9]+>";
final String string = "TEMPLATES\n"
+ "--------------------------------------------------------------\n"
+ ":emote:\n"
+ "<:emote:189855563893571595>\n"
+ "<a:emote:18985556389571595>\n\n"
+ "OK MESSAGE\n"
+ "--------------------------------------------------------------\n"
+ ":emote:<:emote:189855563893571595><a:emote:189855563893571595>\n\n"
+ "BAD MESSAGE\n"
+ "--------------------------------------------------------------\n"
+ ":emote::asdf ::emote::: <:hey:>\n"
+ "<:a:emote:> hey\n\n"
+ "DOES IT WORK?\n"
+ "--------------------------------------------------------------\n"
+ "In the box below (click \"Substitution\" at the bottom if you can't see it) is all the characters that don't match the regex and will trigger your system to delete the message.";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}