import Foundation
let pattern = #":[^:\s]+:|<:[^:\s]+:[0-9]+>|<a:[^:\s]+:[0-9]+>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
TEMPLATES
--------------------------------------------------------------
:emote:
<:emote:189855563893571595>
<a:emote:18985556389571595>
OK MESSAGE
--------------------------------------------------------------
:emote:<:emote:189855563893571595><a:emote:189855563893571595>
BAD MESSAGE
--------------------------------------------------------------
:emote::asdf ::emote::: <:hey:>
<:a:emote:> hey
DOES IT WORK?
--------------------------------------------------------------
In the box below (click "Substitution" at the bottom if you can't see it) is all the characters that don't match the regex and will trigger your system to delete the message.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)