using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-Z][a-z'’]*(?:\s+[A-Z][a-z'’]*)+";
string input = @"The Cow goes moo, and the Dog's Name, is orange""
The mother-daughter bakery, Molly’s Munchies, was founded in 2009";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}