$re = '/\b[A-Z][a-z\'’]*(?:\s+[A-Z][a-z\'’]*)+/m';
$str = 'The Cow goes moo, and the Dog\'s Name, is orange"
The mother-daughter bakery, Molly’s Munchies, was founded in 2009';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);